Jump to content

Recommended Posts

Hey guys.

It had come to some of our attention that with the 2009 revamp. The bass in the stereo mark levinson or standard was poor.

My 2005 prestige pov pack had fantastic power in the bass line. Whilst anything post 09 the system was good but bass was seriously lacking. Hence loud music became very tiney. As I soon discovered with extended time in my 2011 SL.

So I decided to do some more investigating and found the sub woofer used these days is only a single core speaker where the older ones used to be an expensive dual core speaker. And made it difficult to upgrade to an external sub for those serious car audio enthusiasts. (Balancing etc).

I have done a little modding this weekend and since I don't have an old dual core sub, nor four speaker wires at the sub that a dual core requires. I paralleled a second post 2009 ML sub up to the standard ML system / Sub and mounted under the parcel tray next to the existing. And all of a sudden the POWER is back!!

Awesome control and serious bass when you want it. Instead of having bass on full and getting no bass. It sits on half way now and is perfect.

Link to comment
Share on other sites

No.

If you have a pre 09 car there probably is no issue.

But post 09 car there will only be 2 cables going to the sub. So a pre 09 sub will only work half of its potential. Because it needs 4 wires from the amp.

Conecting another post 09 sub is not solving the issue but making do with the issue.

A true fix is a pre 09 amp and wiring loom and speakers.

Lexus have skimped in an area where most ppl probably wouldnt be able to tell.

But with a younger and younger demographic i think they shouldnt have done this.

Link to comment
Share on other sites

Thanks for this info Chris.I too have noticed bass is lacking in otherwise not a bad sound system.I spoke to a car sound guy and he suggested a sub with 2 speakers and integrated amp installed under the drivers seat for $600 installed.Would there be any cheaper options available?

Link to comment
Share on other sites

Hi Chris,

I have a 2008 IS250 EVM pack. I want to install another sub woofer in it. I was wondering if I will be able to connect the new sub to the existing amplifier? or do I need another amplifier ?

Thanks

Link to comment
Share on other sites

sorry for the late reply.

Yes you can but the results may vary. if you want a proper job done and serious power another amped sub should be used.

Link to comment
Share on other sites


  • 11 months later...

You got any pics & how's it holding up now? Is it on par with your pre 09 250? I can seriously tell the difference with the ISF now. The unamplified polk component speakers in my Legnum VR4 sound better than the ML in my ISF. Forced to resort to burning CD's as a temporary fix.

Link to comment
Share on other sites

  • 8 months later...

Hi Chris,

Thanks for that really useful post. I used to own an '05 IS with ML and the sound was pretty decent. First thing I noticed when I moved to an '09 IS was that the ML stereo didn't sound "as good".

i thought I was going insane and imagining things..

I notice that you said you placed a second sub in parallel, wouldn't it be possible then to use a an older dual-core sub and just parallel the two cores off the two wires from the post-09 amp?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership