Jump to content

Recommended Posts

My idle always stay between 500-700 during red stop light, is that normal OR it suppose to stay at 700 since the car always feel shiver when it drops to 500. I have poured the injector cleaner in the fuel tank and I bought the upper engine cleaner foam from Subaru. Does it really needs to be cleaned?

Link to comment
Share on other sites


yes it will do wonders

coconut21 a forum has recently done this at my shop and his ilde is now at 700

before it was @ 400 and felt like it was going to stall

highly recomend you do this

Link to comment
Share on other sites

yes it will do wonders

coconut21 a forum has recently done this at my shop and his ilde is now at 700

before it was @ 400 and felt like it was going to stall

highly recomend you do this

Danny,at how many Ks do you recommend this to be done?

Link to comment
Share on other sites

yes it will do wonders

coconut21 a forum has recently done this at my shop and his ilde is now at 700

before it was @ 400 and felt like it was going to stall

highly recomend you do this

Danny,at how many Ks do you recommend this to be done?

theres really no recomendation

some cars can get build up quickly compared to other cars

its just a matter how u drive it

usual first signs are rough idle

and revs fluctuating at idle

Link to comment
Share on other sites

  • 3 months later...

I just did my carbon clean not long ago and I always use 98 Octane. But today my car start to rattling pretty bad after I turned on air con for like 60 min during driving, it drives ok on the road but rattles bad when the transmission is in P, could anyone suggest something? My air filter is brand new just replaced during last service. The car has done 150000km and spark plugs were replaced during 90000km service.

Link to comment
Share on other sites

I just did my carbon clean not long ago and I always use 98 Octane. But today my car start to rattling pretty bad after I turned on air con for like 60 min during driving, it drives ok on the road but rattles bad when the transmission is in P, could anyone suggest something? My air filter is brand new just replaced during last service. The car has done 150000km and spark plugs were replaced during 90000km service.

To clarify, Wind Chaser, what's your idle speed when the transmission is in P and the car rattles?
Link to comment
Share on other sites

The idle is sitting at 500 but the engine rattles much worse than it was. U know usually when the gear is in P, the idle should go back up a little and this only happens every time I turn on the air cond for a long drive. It disappeared this morning when I took a 15 min drive with cold air turned on. I checked all the hoses seem OK and secure. Do u think it can be the spark plugs or should I do another upper engine clean?

Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership