Jump to content

Touchscreen Needs Calibration But Can't Access Menu


Recommended Posts

Hey guys,

Seems like my Nav/EMV is in need of some love.

I seems to be calibrated to one spot only on the touchscreen

So once I can fluke to finally push the 'I'm a dumbo Murican driver' Push 'Okay' screen and it displays the map i can click anywhere on the screen and it will only goto 3/4 to the bottom and 3/4 right so almost to the okay button which is why you have to fluke it to remove that annoying as hell message.

I can access the service menu but obviously cant click on anything. (Hold INFO, lights on/off)

Has anyone experienced anything similar or know a fix etc?

I have tried some basic fixes.

Hitting it

Cleaning it

Talking nicely to it

Talking not nicely to it.

Caliing it a f&%en piece of $*%t

Tapping the hell out of it.

Resetting it

Turning it off and on

Getting my gf tender hands to try it

I still have to try a cold Boot (Battery disconnect) and pulling fuses etc.

Has anyone else experienced this or is it a case of a broken touchscreen as seen on the US forum.

  • Like 1
Link to comment
Share on other sites

Sounds like you've got the start of the digitiser dying problem! I had that within 6 weeks of buying my 07 IS 250X.

I followed this guide and that fixed it. The other options is to replace the screen unit entirely instead of resoldering the contact points on the digitiser.

https://snapguide.com/guides/fix-the-touchscreen-in-a-lexus-is350/

Link to comment
Share on other sites

  • 2 weeks later...

** Update **

Touchscreen / Radio / Navi is in bits!

Turns out it was the typical dodgy ass digitizer problem going on worldwide.

Circuitwriter pen trick worked a charm but its definitely not for the faint of heart.

FYI:

A couple of things I have learned along the way.

  • Use a dremel not a knife or something to chip the glass as chipping usually removes the copper you need at the same time.
  • The CircuitWriter pen needs time to cure. Approx 24 hours so you may not see the correct resistance straight away.
  • Make sure you shake the *BLEEP* out of the CW Pen until it flows silver. (I thought I must have a new clear version cause it took 4 goes shaking the *BLEEP* out of it to flow silver.
  • Be patient. You will need some mechanical / Electronics experience but the YouTube tutorials should be able to walk most through it
Link to comment
Share on other sites


  • 1 month later...

Gidday Fellas,

First time poster, long time lurker (couple of months actually)

My 2007 touch screen has just started playing funny buggars..

All the side function buttons work on the unit as most people report happens.

I cannot push the " I Agree " button as nothing happens.

If I push the Climate or Audio buttons etc and they appear on the touch screen, I still cannot push or command anything etc.

BUT, If I push the INFO button it will let let choose a command like telephone etc but then once into that screen I cannot push anything else..

I have watched a few of the youtube videos, and walk through procedures so I suppose my need bet is to have a go and repair it myself.

Or should I get the small replacement part that keeps breaking, and if so where do you source these parts in Australia, any good recommendations please.

I would prefer to Plug and Play :) as I have a short fuse with fixing things when the *BLEEP* hits the fan :o :o

Many thanks and any info at all would be very helpful at this stage.

Cheers Grant

Link to comment
Share on other sites

Hi Grant,

Mine needs a re-fix as it just melted at a WTAC sitting in the sun and know about a centimetre from the bottom is non-responsive

If you want to pulls yours apart and send it to me I could fix yours at the sametime.

TBH though I would recommend a new unit as this method of fixing works well but as I have found out the aussie heat can melt the Silver and break the touch screen again.

Its a easy fix but the dismantle of the car then touch screen unit is a pain in the arse.

Gidday Fellas,

First time poster, long time lurker (couple of months actually)

My 2007 touch screen has just started playing funny buggars..

All the side function buttons work on the unit as most people report happens.

I cannot push the " I Agree " button as nothing happens.

If I push the Climate or Audio buttons etc and they appear on the touch screen, I still cannot push or command anything etc.

BUT, If I push the INFO button it will let let choose a command like telephone etc but then once into that screen I cannot push anything else..

I have watched a few of the youtube videos, and walk through procedures so I suppose my need bet is to have a go and repair it myself.

Or should I get the small replacement part that keeps breaking, and if so where do you source these parts in Australia, any good recommendations please.

I would prefer to Plug and Play :) as I have a short fuse with fixing things when the *BLEEP* hits the fan :o :o

Many thanks and any info at all would be very helpful at this stage.

Cheers Grant

Link to comment
Share on other sites

Hi,

Thanks for the offer and feedback, I have been reading and watching youtube vids on the procedure over the weekend and yes I think I would prefer a new screen to go in which will be easier for myself to do.

Just wondering are there different quality screens etc, do you recommend a good seller in Australia or is ebay the only source to buy one from.

many thanks once again for your help

Cheers Grant

Link to comment
Share on other sites

  • 1 month later...

Gidday,

Yesterday after reading about and then watching the "walk throughs" on the screen repairs etc I went about replacing mine, took about 3 hours from start to finish, the worst bit was removing the front air vent as mine just would not come out easily like in the videos etc. but apart from that it was easy to do as I took photos and then dismantled the unit and done the repair beside the computer on the desk inside with good lighting.

I had brought the replacement screen from the UK delivered for about $80.00 in total and everything went in well, I had to remove the original glass screen which took a bit of going and snapping of glass etc and then clean up around the edges where the glue or double sided tape was located, then I installed the new screen as is and it all sat nice and solid..

Everything works again as it should and the screen colour is great.

Link to comment
Share on other sites

Sounds great so you kept the digitizer and replaced the screen ?

or Both ?

Pics would be great as I'll think i'll do the same as I don't want to do the cheap fix again for it to just die from the heat.

Do you have a link to the where you got the screen from ?

Link to comment
Share on other sites

Hi,

This is what I brought, it fitted and plugged straight in etc. I wouldn't stuff around trying to fix the old one for the money..

I took not real pictures of the job, only daggy close ups of the back of the unit with the wires still connected when I first moved it forward just as a guide for myself but have since deleted them..

http://www.ebay.com.au/itm/261975380319?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

Link to comment
Share on other sites


Awesome cheers for that. What year is your IS ?

Do you just remove the old digitizer with a knife then add the new digitzer with adhesive provided etc.

All for $80.

Take my money!!!

Yay no more Googly maps!

Hi,

This is what I brought, it fitted and plugged straight in etc. I wouldn't stuff around trying to fix the old one for the money..

I took not real pictures of the job, only daggy close ups of the back of the unit with the wires still connected when I first moved it forward just as a guide for myself but have since deleted them..

http://www.ebay.com.au/itm/261975380319?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

Link to comment
Share on other sites

Hi,

The old glass screen is actually stuck on there really well with a small thin bead of glue or some type of thin double sided tape, so what I done was got a new blade in a Stanley knife and gentle went around the 4 x edges multiply times, then I got a bigger stronger pocket knife blade and forced it in very gently to price open a section on the glass and yes this is where it broke and cracked, then once opened and then carefully removed all the glass, please note to do this away from your working area as small pieces of glass were flying here and there.

KEEP YOUR KNIFE EDGE AWAY FROM THE SCREEN !!!

Once the glass was all removed I then picked at the very small rough pieces that were still attached to the glue/tape etc. I cleaned these up and smooth it down BUT it left the glue/tape there to help with the install on the new screen.

I thought about new glue but then decided NO as it would make it messy and I did not no how the new screen would react with a glue or tape etc, so I went about just installing it all back together and once it was all screwed in place and the brackets put pressure on it, the screen locked into place fine with the help of enough remaining old glue/tape left in place.

Basically I was winging it here and it work out great - Best of Luck :)

Link to comment
Share on other sites

  • 2 weeks later...

So weird!.

FYI there is only 12 plugs.

This time it did the reboot initialize thingy and it worked.

Grrrrr chasing my tail for a whole day.

Still fixed with new digitizer.

Alot better fix for the summer months than the dodgy circuit pen trick 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership