Jump to content

No sound coming from the speakers


Duns

Recommended Posts

I’ve been a Lexus owner now for 10 years. Never had an issue until now. Have just joined this forum hoping to get some help. I currently own a 2014 IS350 F Sport which I’ve had for 5 years. A week ago the speakers in my car suddenly stopped working. There is no sound from radio, or the navigation system nor the phone connection.

After several days of google searches I found some answers from international sites putting it down to either a problem from one of the speakers causing all of the speakers not to work or from the amp.

Has anyone else had this issue and how did you best resolve it? I called Lexus today and they quoted me $2,400 to instal a new amp.  Trying to find a self fix solution if anyone can offer some advise.

The quietness while driving is deafening, please help.

Link to comment
Share on other sites


yes its becoming common on the newer IS

the best way to go about this is 

call up a wrecker and get a 2nd hand amp and put it in

be around the 400 to 500 mark

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...




Forums


News


Membership