Jump to content

GS450H 2007 Model Hybrid problems


davo1

Recommended Posts

Hi everyone...have had our GS450H for almost 3 years now, had the check hybrid error come up a few months after getting her...had a taxi mechanic change out a couple of cells and it was good for over a year. just had the codes come up again, the same mechanic changed another couple of cells, seemed good but a few days later, the error comes up again...we do a long drive to Adelaide and back (Gold Coast...5000kms), it only goes off maybe twice...(I have a Foxwell scanner to clear the codes) he does he work again, this time when we get it back going off several times a day...constantly...no other codes except for the ecb and vscĀ ones...I am wondering if it could be the converter or even heard that sometimes the gearbox could be at fault (something to do with the oil?) Do not really want to get a new Hybrid battery and then find out it is something else as well...any thoughts are really appreciated

20181207_111750[1].jpg

20181207_111753.jpg

20181207_111805.jpg

20181207_111825.jpg

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...




Forums


News


Membership