Jump to content

HELP: 2007 RX350 High Idle Fault Code P0015


Recommended Posts

Help please

My 2007 RX350 won't idle below 1800rpm in neutral and 1200rpm when in gear. Also showing fault code P0015 which indicates "B" camshaft position timing over retarded (Bank 1).

However car runs perfectly. Easy start. No timing chain rattle, very smooth, no noises. No stalling. With P0015 you would expect strange noises and rattles. And strangely, the MIL (malfunction indicator lamp, a.k.a. the check engine light) does not come on.

Read more at: http://www.obd-codes.com/p0015

Any ideas please? Can't see how the high idle and P0015 can be related. Have checked for inlet manifold leaks and throttle-body gasket leaks. All clear. Air cleaner is also new with no obstructions.

Could there be an internal leak within the throttle body? Don't see how? What about cam sensors?

Any Toyota / Lexus techs out there please?

Cheers, David

Link to comment
Share on other sites


Try disconnecting the battery for 10 mins see if it helps, any air leaks around the throttle body have they got a idle air control valve? could be carbon up and check the connections on the camshaft bank, let us know what you find good luck. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...




Forums


News


Membership